Upgrade ITM6 WPA

iKnow-IT banner

root<DEV>@<hostname> <WPA> /mnt/ITM6.2.3/ITM623FP5/6.2.3-TIV-ITM_TMV-Unix-FP0005 # ./install.sh
install.sh warning: The current limit of maximum number of open files allowed is too small; this might cause the installation to fail. It is recommended to increase this limit by 1000, continuing ...

Continue with this installation [ 1-yes, 2-no; "1" is default ]? 1
UPGRADE

ITM home directory "/opt/IBM/WPA/ITM" already exists.
OK to use it [ 1-yes, 2-no; "1" is default ]? 1

Select one of the following:

1) Install products to the local host.
2) Install products to depot for remote deployment (requires TEMS).
3) Install TEMS support for remote seeding
4) Exit install.

Please enter a valid number: 1

Initializing ...
International Program License Agreement

Part 1 - General Terms

BY DOWNLOADING, INSTALLING, COPYING, ACCESSING, CLICKING ON
AN "ACCEPT" BUTTON, OR OTHERWISE USING THE PROGRAM,
LICENSEE AGREES TO THE TERMS OF THIS AGREEMENT. IF YOU ARE
ACCEPTING THESE TERMS ON BEHALF OF LICENSEE, YOU REPRESENT
AND WARRANT THAT YOU HAVE FULL AUTHORITY TO BIND LICENSEE
TO THESE TERMS. IF YOU DO NOT AGREE TO THESE TERMS,

* DO NOT DOWNLOAD, INSTALL, COPY, ACCESS, CLICK ON AN
"ACCEPT" BUTTON, OR USE THE PROGRAM; AND

* PROMPTLY RETURN THE UNUSED MEDIA, DOCUMENTATION, AND

Press Enter to continue viewing the license agreement, or
enter "1" to accept the agreement, "2" to decline it, "3"
to print it, "4" to read non-IBM terms, or "99" to go back
to the previous screen.
1

Product packages are available in /mnt/ITM6.2.3/ITM623FP5/6.2.3-TIV-ITM_TMV-Unix-FP0005/unix

The following products are currently installed in "/opt/IBM/WPA/ITM":

IBM GSKit Security Interface V07.40.47.00 @ AIX R5.2 (32 bit)/R5.3 (32 bit) AIX R6.1 (32 bit)
IBM GSKit Security Interface V07.40.47.00 @ AIX R5.2 (64 bit)/R5.3 (64 bit) AIX R6.1 (64 bit)
Tivoli Enterprise Services User Interface V06.23.01.00 @ AIX R5.3 (64 bit) AIX R6.1 (64 bit)
Warehouse Proxy V06.23.01.00 @ AIX R5.3 (64 bit) AIX R6.1 (64 bit)

 

The following prerequisites should be installed now:

IBM Tivoli Monitoring Shared Libraries V623R100 @ AIX R5.3, R6.1, R7.1 (64 bit)
Tivoli Enterprise Services User Interface V623R100 @ AIX R5.3, R6.1, R7.1 (64 bit)

Do you want to install these prerequisites [ 1=Yes, 2=No ; default is "1" ] ? 1
... installing package "axaix536"; please wait.

=> installed package "axaix536".
... installing package "uiaix536"; please wait.

=> installed package "uiaix536".
All agents require that application support files that contain agent-specific information be installed on the Tivoli Enterprise Monitoring Server that the agents will connect to, Tivoli Enterprise Portal Server and Tivoli Enterprise Portal desktop and browser client. Install application support before starting to install any Tivoli Enterprise Monitoring Agents.

Product packages are available for this operating system and component support categories:

1) IBM Tivoli Monitoring components for this operating system
2) Tivoli Enterprise Portal Browser Client support
3) Tivoli Enterprise Portal Server support
4) Tivoli Enterprise Monitoring Server support
5) Other operating systems

Type the number or type "q" to quit selection
[ number "1" or "IBM Tivoli Monitoring components for this operating system" is default ]: 1

You selected number "1" or "IBM Tivoli Monitoring components for this operating system"

Is the selection correct [ 1=Yes, 2=No ; default is "1" ] ? 1

The following products are available for installation:

1) Summarization and Pruning Agent V06.23.05.00
2) Tivoli Enterprise Monitoring Server V06.23.05.00
3) Tivoli Enterprise Portal Server V06.23.05.00
4) Tivoli Enterprise Services User Interface Extensions V06.23.05.00
5) Tivoli Performance Analyzer V06.23.05.00
6) Warehouse Proxy V06.23.05.00
7) all of the above

Type the numbers for the products you want to install, type "b" to change operating system, or type "q" to quit selection.
If you enter more than one number, separate the numbers by a comma or a space.

Type your selections here: 6

The following products will be installed:

Warehouse Proxy V06.23.05.00

Are your selections correct [ 1=Yes, 2=No ; default is "1" ] ? 1

... installing "Warehouse Proxy V06.23.05.00 for AIX R5.3, R6.1, R7.1 (64 bit)"; please wait.

=> installed "Warehouse Proxy V06.23.05.00 for AIX R5.3, R6.1, R7.1 (64 bit)".
... Initializing component Warehouse Proxy V06.23.05.00 for AIX R5.3, R6.1, R7.1 (64 bit).
... Warehouse Proxy V06.23.05.00 for AIX R5.3, R6.1, R7.1 (64 bit) initialized.

 

Do you want to install additional products or product support packages [ 1=Yes, 2=No ; default is "2" ] ? 2
... postprocessing; please wait.
... finished postprocessing.
Installation step complete.

You may now configure any locally installed IBM Tivoli Monitoring product via the "/opt/IBM/WPA/ITM/bin/itmcmd config" command.

Automatic start at system initialization has been configured.
You must manually configure automatic stop at system shutdown. Create or modify /etc/rc.shutdown to invoke the command '/etc/rc.itm4 stop'. Refer to AIX documentation for more information about /etc/rc.shutdown.
Executing command: /opt/IBM/WPA/ITM/bin/secureMain -g itminf lock
Enter the root password if prompted
secureMain completed successfully
The Warehouse Proxy and/or the Summarization and Pruning agents are not started automatically after the upgrade is completed. Dependent upon the installed agents and the associated attribute groups enabled for historical collection and whether limited database permissions are granted to the warehouse user, a database administrator might need to use the Warehouse Publication Tool to generate a script with the necessary changes for the database. Information regarding these required steps can be found in the IBM Tivoli Monitoring Installation and Setup Guide.
root<DEV>@<hostname> <WPA> /mnt/ITM6.2.3/ITM623FP5/6.2.3-TIV-ITM_TMV-Unix-FP0005 #